2

I occasionally get a message in Superuser that it works better with Java script enabled. However, when I go to Javascript, it is already enabled.

Why would this happen?

I'm using Windows XP and Firefox version 3.6.3.

EDIT: The same flag has now come up on Meta. Edit: I have discovered that this is triggered by some program I have installed in Firefox. I notice that as I get to the end of a page, if ther is another page, a pop-up box appears at the bottom right corner and says: "Loading next page". Immediately after that, I get the "Javascript message.

7
  • 2
    What version of Firefox? Are you running no-script or any other addon that may interrupt regular javascript operation?
    – Jonathan Sampson
    May 16, 2010 at 18:51
  • Version 3.6.3. I am not running another toolbar. Thanks
    – Xavierjazz
    May 16, 2010 at 18:58
  • ps: not running no script either.
    – Xavierjazz
    May 16, 2010 at 20:09
  • adblock? firebug?
    – forget it
    May 16, 2010 at 21:20
  • None of those...
    – Xavierjazz
    May 17, 2010 at 0:58
  • Go to Tools>Add-ons and tell us what's listed in the first pane there.
    – Hello71
    Jul 14, 2010 at 17:11
  • sigh for people who say "Java script" or even gasp! just "java".
    – Hello71
    Jul 23, 2010 at 3:01

1 Answer 1

1

This should only appear if JavaScript is disabled. View source to see why..

<noscript> 
    <div id="noscript-warning">Meta Stack Overflow works best with JavaScript enabled</div> 
</noscript> 

See noscript tag documentation

9
  • 1
    I'm not highly computer literate. How do I "view source"?
    – Xavierjazz
    May 17, 2010 at 0:59
  • OK. I found "view" and looked at "page source". What am I looking for?
    – Xavierjazz
    May 17, 2010 at 1:15
  • 1
    @Xavierjazz No need to hunt it down yourself - Jeff posted the relevant source above.
    – Jonathan Sampson
    May 17, 2010 at 3:18
  • 1
    @xavier what I mean is, there has to be something wrong with your browser configuration to see this -- by W3C standards definition it means JavaScript is somehow disabled for you. Have you tried in a different browser? May 17, 2010 at 3:41
  • Not yet, thanks. Too busy. I'll let you know.
    – Xavierjazz
    May 18, 2010 at 23:47
  • I have discovered an aspect of the problem. Please see the question again for the edit. Regards.
    – Xavierjazz
    May 25, 2010 at 20:53
  • @Jeff I am also having the same sporadic problem within Chrome (6.0.472.63, portable install). I have Javascript enabled for all sites, and this seems to only happen on the older Stack sites' parent sites. Meta sites and all Area51 gen work as expected.
    – mfg
    Oct 20, 2010 at 14:37
  • @mfg we have no other reports of this and use Chrome 6 every day across the entire dev team. I strongly suspect whatever "portable install" is, that might be your issue. Oct 20, 2010 at 15:57
  • Unfortunately, you're probably right. I guess I was hoping (?) there were other reports and a fix.
    – mfg
    Oct 20, 2010 at 17:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .