8

The Election information page doesn't seem to like SuperUser.

When you load the page, only the Loading elections page item is ticked and then the checklist disappears. However, the page continues to display the following even though multiple people have already nominated:

No one has braved the nomination process yet! Check back later.

Note that all other site elections seem to work, including sites that have a custom domain name like SU (e.g. ServerFault)

The SU election is the first election since plans for network-wide HTTPS was announced. Maybe some preliminary changes related to this have stuffed something up?

Repro'd on Firefox and Chrome. The election has been up for almost 10 hours now, so I don't think that I should blame caching.

  • I seem to recall that the election site is kinda vaguely unofficial. Dropped a few notes, and we can see where things go. Most of the information that was on there should be on the nomination pages though? – Journeyman Geek Mar 14 '17 at 7:49
  • @JourneymanGeek the page collates a bunch of information from all over the user's profile, meta profile, etc, which would take quite a while to collate manually. It's not all avaliable on the nomination page. – angussidney Mar 14 '17 at 8:00
5

Maybe some preliminary changes related to this have stuffed something up?

Yeaaaaaaaaaaaaaaah. Emergency fix in and deployed now. There are several other related and unrelated issues that I will get to fixing later today, but for now the candidates should show up and things should mostly* work.

As a funny side note, the fact that all other sites were working is something you can blame on caching, since completed elections don't make a roundtrip to the site and therefore didn't trigger this bug.

*I'm aware of issues with the site icon and badge counts, along with some additional http → https conversions that should be made currently. Anything else please pass along to me so I can get it sorted!

  • 1
    hello timmeh \o – Sathyajith Bhat Mar 14 '17 at 10:44
  • For intrest's sake, is the source code for the app avaliable publicly and can we submit bug fixes to it? Or is it private? – angussidney Mar 14 '17 at 11:01
  • @angussidney On Github, though it's in fairly rough shape/will be getting a fairly significant overhaul soon (granted, I've said that about many things many times, but >_>) – Tim Stone Mar 14 '17 at 11:03
  • Working better in Chrome. Still horribly broken in FF. – DavidPostill Mar 14 '17 at 20:39
  • odd. Works for me. Horribly broken how? – Journeyman Geek Mar 15 '17 at 0:04
  • @JourneymanGeek If the images aren't in your cache, Firefox's alt text behaviour makes it look pretty bad...will get that bit sorted out soon-ish – Tim Stone Mar 15 '17 at 0:05
  • @JourneymanGeek It get stuck loading "Loading user profile on main site". Disabling httpseverywhere fixes it. – DavidPostill Mar 15 '17 at 17:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .