I logon to SU using my google Id and use Chrome browser to access it. However, It logs me off after every few minutes. Google keeps me logged on and i can access all my things there (emails and other websites). But on SU, I need to click LogIn every time and need to select google as login method.

I keep the browser updated to latest version (current Version 67.0.3396.99 (Official Build) (64-bit)). Using Windows 8.1 Pro 64-Bit.

I have tried deleting browsing history, saved files, cookies etc. But, it has not solved the issue.

How can I resolve this problem.

  • Deleting cookies will log you out. As will if you are running in incognito mode. – Burgi Jul 4 at 15:42
  • Any extensions installed? Also, make sure you don't have Chrome configured to clear cookies. – Shog9 Jul 4 at 15:42
  • Does the problem occur with any other Stack Exchange sites or is it unique to Super User? – Mokubai Jul 4 at 17:09
  • This is unique to SU only. Though, I know if we use SE and SU both, we can logon to any one of them only. I also need to check setting of cookies and extns as mentioned in other comments. – Sandeep Jul 4 at 17:22
  • It turned out that an extension Redmorph was causing this issue. I installed it to block tracking code and cookies. I reduced the security settings for SU. Now, it is working fine since morning. Documentation of this extension also suggest to do that, in case if user feel some issues with website. – Sandeep Jul 5 at 14:38
  • 1
    @Sandeep Good find. Please post that as an answer instead of a comment. – Twisty Impersonator Jul 6 at 14:22
up vote 3 down vote accepted

After getting few inputs in comments about cookies and extensions; i checked my settings. Settings for cookies were correct. Then I disabled all extensions installed and tried enabling them one at a time. It turned out that one of the extensions was causing this issue. Few months back, I installed redmorph extension to block tracking scripts and cookies. In this extension, security settings were set to default for all websites. When I went through the documentation, it was mentioned that some websites may not work with default settings. In that case user need to change security setting for that website in order to make it work. I reduces settings to None for SU and it is working fine since then.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .