In this question: Bash: I want to type a tilde. Pressing F10 gives me '1~' instead of just '~', the OP eventually posted their own answer, describing how they solved the issue described in the question:

I fixed this my removing ~.inputrc which had nothing useful in it anyway.

Somehow, despite being literally the answer to OP's problem (a really poor solution, but a solution that worked for them nevertheless), the post

  1. got a comment saying "This does not provide an answer to the question. To critique or request clarification from an author […]"
  2. was deleted by a moderator.

I assume the commenter didn't realize that the post was by the author, so in this thread I'm mostly wondering whether the mod-deletion was justified.

  • 2
    I've undeleted it, but it is still a very poor answer, as it doesn't explain why removing ` ~.inputrc` resolved the issue, which makes it pretty much useless for any one else reading the question. – DavidPostill Sep 24 at 20:25
  • 8
    @DavidPostill while I agree that the answer could be improved, it does indicate a working solution, and points other with same problem that that one file is problematic (so they can try moving it away, and if it helps, then possibly triage what exactly in it is causing the problem - or leave it removed if they don't care about it). – Matija Nalis Sep 27 at 12:57

You must log in to answer this question.

Browse other questions tagged .