1

When I start answering a question on superuser, with Firefox 11 on OSX 10.7, then swipe back (two finger swipe using the touchpad on my macbook), I get the following notice. It seems like a javascript-alert. The catch: neither of the buttons work. The only way to get out of there is to kill the browser. I've had this twice today. It seems like a javascript-bug. I cannot close the window, or switch to other tabs, although other windows keep on working.

When I start a new question, the same happens. I've tried this again, and it seems like the first test was when the answer was already saved by the website, and then it worked. Now I discarded the old question, started with a clean question, and then it happens as well.

When I use the back-button in the browser, it works like expected.

Screenshot of the popup


Safari (OSX)

I just tested the same situation with Safari. I should tell you that I have a Macbook with the multitouch touchpad. I do not use the back-button in the browser, but I use a double finger swipe to go back. And that is the cause of the problem. When I use the back-button, the page reacts like expected. The popup appears before leaving the page, and I choose to leave or stay. When I use the swipe, I go back to the previous page, and then the popup appears. If I choose to leave, no problem. If I choose to stay, then the page turns white. The same happens when asking a new question. Writing a comment doesn't cause any issues.

  • It probably should be this dialog (FF 11 on Win 7), which appears when trying to leave pretty much any page when I've started entering something (eg, writing a question, answer or comment). Does this sometimes work successfully? Can you repro on any other input page (eg, start giving a comment and try then)? Can you repro another SE site? – DMA57361 Apr 11 '12 at 17:37
  • I changed the question, because this only happens when using the touchpad to go back (swiping). The back button works normally. I made the wrong assumption that the back button and the back-swipe would be identical for the browser. So this is probably an OSX only problem. It happens in Safari in a different way. I described that as well. – SPRBRN Apr 12 '12 at 11:21
  • I did another test with a new question, and it happens there as well. See my comment. Google Chrome works OK btw! – SPRBRN Apr 12 '12 at 11:40
  • 1
    Three finger swipe in Safari works for me, the rest bugs differently than you describe here. But Safari 5 is one giant bug anyway, I have filed 3 bugs at least. Not an issue with SU. bugreport.apple.com – Daniel Beck Apr 12 '12 at 19:51

You must log in to answer this question.

Browse other questions tagged .