2

If a comment flag is the first flag a user has on a site, then even if that flag is marked helpful, it will not show up on the flag summary page.

As soon as an another valid (non-comment) flag is accepted, the flag count on the right will update to show that there are now two valid flags, one comment, and one post.

While I understand that this is accepted behavior, it is pretty confusing, and should change.

  • Weird. Definitely a bug - I checked some other users with flags on meta and they've all got the badge and the flag history page showing up correctly. I'll pass this along to the team. – nhinkle Apr 19 '12 at 5:31
  • huh, I noticed it last night. Was about to act on it but it got vanished. Figured another mod acted on it, so didn't bother then – Sathyajith Bhat Apr 19 '12 at 5:33
  • @soandos do you have a link to the flagged post? Curious to see what shows up in the flag page there. – nhinkle Apr 19 '12 at 5:52
  • Wait, it was a comment? I'm pretty sure comments don't show up in your flag history. Although they also shouldn't count towards your "valid flag" count. That explains not getting the badge though. It's only for first flagged post, which I think only applies to flags on questions and answers. – nhinkle Apr 19 '12 at 5:59
  • It was, but on the main site, I have a section for comments that were flagged (though I think at some point whether or not the flag was not was not tracked, so not all the numbers add up). I have no corresponding section on MSU. – soandos Apr 19 '12 at 6:00
  • Shoot. I went to flag your previous comment so I could test what it would do to my flag history, and it just straight-up deleted the comment. Apparently any comment flag by a moderator outright obliterates the comment right away. Oops. – nhinkle Apr 19 '12 at 6:03
  • Anyhow, from my testing gone awry, it appears that this is expected behavior. If you've only ever flagged a comment, it'll show you (1) helpful flags but it won't show anything in the flag review. Try flagging an actual post (this one would work for a test) and see what happens. – nhinkle Apr 19 '12 at 6:04
  • This is rather confusing expected behavior. Why does it not say that there was a comment flag that was valid? – soandos Apr 19 '12 at 6:05
  • @nhinkle This (flagging) is the appropriate moderator action for spam flags, by the way. Deletion doesn't mark others' flags helpful, and it'd break spam stats IIRC. – Daniel Beck Apr 19 '12 at 6:05
  • If it's a comment flag, at least the missing badge is no actual issue -- First flagged post... – Daniel Beck Apr 19 '12 at 6:06
  • @nhinkle, flag marked valid, and now the comment flag count is shown. That should not be expected behavior.... – soandos Apr 19 '12 at 6:06
  • @soandos now your profile is showing correctly 1 valid regular flag and 1 valid comment flag, and as expected, doesn't show the comment (because once comments are gone, they're gone*). – nhinkle Apr 19 '12 at 6:07
  • I mean that now it shows that there was a comment flag, where before it didn't. – soandos Apr 19 '12 at 6:08
  • @DanielBeck right, I pointed out the thing about the badge above. As for flagging, I put a custom flag, not a spam flag, so it should've just shown the flag. That is the normal behavior with spam flags, but this was a comment flag. I think it's because with a comment, the only choices are "delete" or "dismiss," so the system figures that if a mod flagged a comment, then of course they're not going to dismiss it. – nhinkle Apr 19 '12 at 6:09
  • @soandos right - they could make it more clear when you only have a single comment flag what's going on. There's nothing broken with your account though at the moment. Perhaps this should be retagged as a feature request, and edited as such? – nhinkle Apr 19 '12 at 6:10

You must log in to answer this question.

Browse other questions tagged .