5

I have a stack exchange account and there's a nondescript error when I try to log into Superuser.com using my Stack Exchange Open ID. At least I think that's what's happening.

This is the error that I get:

Unable to log in with your OpenID provider:

    The openid.return_to parameter (http://superuser.com/users/authenticate/?s=0c617a34-f614-4eb2-96f9-dbf510fd44e1&dnoa.userSuppliedIdentifier=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F8b212e9c-65ed-4978-875b-0d13732bffdc) does not match the actual URL (https://superuser.com/users/authenticate/?s=0c617a34-f614-4eb2-96f9-dbf510fd44e1&dnoa.userSuppliedIdentifier=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F8b212e9c-65ed-4978-875b-0d13732bffdc&openid.claimed_id=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F8b212e9c-65ed-4978-875b-0d13732bffdc&openid.identity=https%3A%2F%2Fopenid.stackexchange.com%2Fuser%2F8b212e9c-65ed-4978-875b-0d13732bffdc&openid.sig=IK1EY%2F6un8SuXzyI%2ByGoB8oPhDCM%2FGXmE5VO6%2FgHDu8%3D&openid.signed=claimed_id%2Cidentity%2Cassoc_handle%2Cop_endpoint%2Creturn_to%2Cresponse_nonce%2Cns.alias3%2Calias3.mode%2Calias3.type.alias1%2Calias3.value.alias1&openid.assoc_handle=1Ltb%21IAAAAJyM8vKbBOESXhm997BwPXtnIwbZP791FBHzNfHcmJvzQQAAAAEwjPe-LFVBEO3U0uoVOvqDTIVhCuGvNYGmst-QpSRpoTQ63oKo7Q1QEk6z2aSJcwh4lLbY_yGyYUztwINRDyw7&openid.op_endpoint=https%3A%2F%2Fopenid.stackexchange.com%2Fopenid%2Fprovider&openid.return_to=http%3A%2F%2Fsuperuser.com%2Fusers%2Fauthenticate%2F%3Fs%3D0c617a34-f614-4eb2-96f9-dbf510fd44e1%26dnoa.userSuppliedIdentifier%3Dhttps%253A%252F%252Fopenid.stackexchange.com%252Fuser%252F8b212e9c-65ed-4978-875b-0d13732bffdc&openid.response_nonce=2014-01-08T22%3A45%3A42ZnvtH8qkd&openid.mode=id_res&openid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0&openid.ns.alias3=http%3A%2F%2Fopenid.net%2Fsrv%2Fax%2F1.0&openid.alias3.mode=fetch_response&openid.alias3.type.alias1=http%3A%2F%2Faxschema.org%2Fcontact%2Femail&openid.alias3.value.alias1=allanonmage%40gmail.com) the request was made with. 

There's an option to reset account and an option to log in with another provider. My gmail account throws a similar, if not the same, error.

I can log into Stack Exchange and Stack Overflow fine.

I have tried logging out and then logging in. No change.

  • Of course, Stack Exchange knows my name, so it pulled my name from somewhere and wants me to add a password to complete my account.... – user288133 Jan 8 '14 at 22:54
4

Are you using HTTPS Everywhere? If so, temporarily disable it for Stack Exchange sites — it seems to be breaking the login page. I encountered this same error earlier today.

See "Can't login with Stack Exchange OpenID when HTTPS-Everywhere plugin is active - apparent protocol mismatch" on Meta Stack Overflow

You must log in to answer this question.