1

I was trying to access superuser.com from a computer at work and got a message telling me to upgrade to Microsoft Edge, Google Chrome, or Firefox. At the time I was using Microsoft Edge 42.17134.1.0 and Microsoft EdgeHTML 17.17134 © 2018 Microsoft.

Superuser.com upgrade to Microsoft Edge

3
  • Related: meta.stackexchange.com/questions/56161/…
    – Mokubai Mod
    Jul 27 at 15:15
  • I'm guessing its a 'trident' based edge vs a chromium based edge
    – Journeyman Geek Mod
    Jul 28 at 8:26
  • @JourneymanGeek - EdgeHTML last version was 18, and became unsupported by Microsoft in April, SE only supports supported browsers. Author already confirmed their client hadn’t updated their Windows installation which meant Legacy Edge was installed. EdgeHTML 17 was released 3 years ago. Trident by the way was Internet Explorer while EdgeHTML replaced it and known as Edge. Chromium is the browser while Blink is the engine. 17134 Is 1803 released in April 2018 almost 18 months out of support.
    – Ramhound
    Jul 28 at 12:24
3

The oldest version of Edge officially supported by StackExchange is Edge 91.

https://browsers.stackoverflow.design/

Screenshot



How I found this:

enter image description here


enter image description here


enter image description here

2
  • Wow, obsolete at only three years old. Thanks for the search tip.
    – Tim
    Jul 27 at 15:19
  • @Tim - All versions of Legacy Edge are not supported, since it was formally discontinued earlier this year, and was removed from all supported version of Windows 10 in April 2021.
    – Ramhound
    Jul 27 at 16:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .