0

I tried to subscribe to a tag on SU, I've got the confirmation mail but the link renders with )### appended to it in Plain-Text Mode, which will result in a 404 not found.

###[Confirm Subscription](http://stackexchange.com/filters/email-confirm/123456)###

I'm using Opera Mail client.

Suggestions:

  • Adding a space in between solves the issue without breaking the markdown.
  • Offering an option for receiving newsletters as PlainText.
  • Great .. I voted to close this question, I thought i can move it to meta.StackOverflow.com – user8228 Jun 20 '12 at 10:47
  • You can flag it for moderator attention to migrate it. – slhck Jun 20 '12 at 11:35
  • 1
    @Revolter it's perfectly OK to ask questions that apply to the whole network here on Meta Super User. I've dismissed your flag for now, but if you really, really want to move it to MSO, then flag it again and we can do that for you. – nhinkle Jun 20 '12 at 17:26
1

The confirmation emails appear to be sent as plain text with an HTML copy attached (as is typical for HTML emails); if your email client has been set to display HTML emails you will see that version instead.

The plain text version is Markdown formatted. Yes, that same thing Stack Exchange uses. Markdown is designed to be readable when sent as plain text, and I assume some email clients will render it formatted properly too.

What you are seeing is a Markdown inline link enclosed in a header. It's perfectly valid. What's likely actually happening is your mail client is interpreting the http://ValidURICharacters as a link, and included the )### in it. It is both technically valid Markdown and a technically valid URI, so...

An easy fix for you is to use a HTML or Markdown compatible email client (or enable it if you have it disabled). Or you can copy and paste the URL manually; after all, with plain text emails, the clickable link is merely a convenience provided by your email client.


###[Confirm Subscription](http://stackexchange.com/filters/email-confirm/123456)###

renders as

Confirm Subscription

in Markdown


As an aside, Thunderbird appears to highlight the link without the )### when viewing in plain text mode. I'm pretty sure that's technically incorrect, but it probably works more often.

  • it works fine when I use HTML, I only prefer reading my emails as plain text and without extra stuffs (I think I'm not the only one). actually separating the )### from the link with a blank space fixes the problem and without breaking the Markdown. I don't know if this the proper way to report bugs. – user8228 Jun 18 '12 at 9:15
  • I wouldn't really consider it a bug as such, since everything is technically valid. It's really just those plain text email clients that want to make things that 'look like links' clickable. Perhaps others may have a differing opinion, or a SE team member will give an official word on this (you may have more success on the meta.stackoverflow.com site, which is the network wide meta - also, try giving a specific suggestion, such as adding the space). – Bob Jun 18 '12 at 9:20
  • I guess you could also request an option (on the user profile/tag subscription page) to send emails as non-Markdown plain text. – Bob Jun 18 '12 at 9:27

You must log in to answer this question.