0

I was looking at the "Review, first questions" pages (month view, not random), when something suspicious caught my eye:

Every question has at least 1 upvote! Also, the questions are not ordered properly, and seem to skip around, date-wise. I would expect the newest questions up top.

Is this a new, "be kind to newbies" initiative?   A display error?   Hidden controls?   What?

Page 1 (Click to view the very large image):
First page of results

One of many date-sort problems:

Date sort problems


Update:

This turned out to be bad UI design:

  1. Useless default sort order
  2. Sort controls hidden in a poor location where studies prove most users will not see them (4 pages down, in the right-hand column!!).
  • 1
    Maybe I'm missing something but they seem to be ordered correctly. – James Mertz Jul 23 '12 at 1:47
  • @KronoS, Look at the screenshot or go to the page. They jump from June 29, to June 23 02:44, to June 23 08:12, etc., etc. Later pages have more recent dates July 3rd, etc. ... ... These posts are in no usable order, even if there is some bizarre pattern to them (which remains to be seen). – Brock Adams Jul 23 '12 at 1:54
  • 1
    It looks like they're ordered by votes then date. Still don't see the error. – James Mertz Jul 23 '12 at 2:01
4

I just checked this and I'm not having any issues that you're describing above. Here's a small snapshot of what I see when I do month view and sorted newest first:

enter image description here

I would check to make sure that you've selected the newest first sorting if you're looking to sort by date:

enter image description here

  • 1
    Okay, that was it. I did not see the "Custom Sort" links because they were hidden 4 pages down, in the right-hand column!!! (What kind of UI design is that? The default sort order leaves much to be desired, too.) – Brock Adams Jul 23 '12 at 6:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .