1

i use Chrome and notscripts, recently get a failure to authorize with stackexchange and cannot chat with a moderator anymore.

http://chat.stackexchange.com/help

Is this a problem with the recent update to Chrome?

Clearing or resetting HTML5 as suggested does not help, how to do this manually?

Fails in Incognito mode also.

How do I sort this out, thanks.

Chrome version 13.0.782.107 m

enter image description here

enter image description here

.

If I disable Notscripts, still not working.

Clean re-installed Chrome Error persists, Looked in my local storage folder and this file was in there "http_chat.stackexchange.com_0.localstorage"

enter image description here

POSSIBLE CAUSE: Appears that setting "Ignore exceptions and block third-party cookies from being set" in chrome options causes this error, I have had it set this way for a long time, but now it causes problems, strange, uncheck the box and all is fine, toggle it back and error returns.

Can some one else verify this?

.

  • I just tried logging into chat.stackexchange.com, and I had no problems using the latest version of Chrome. What happens in Incognito mode (which should disable all extensions by default)? Have you tried a fresh install of Chrome? My guess is NotScripts is causing the problem. – nhinkle Aug 4 '11 at 23:04
  • Try reinstalling Chrome fresh, with no extensions. I have the exact same build of Chrome and no problems. – nhinkle Aug 4 '11 at 23:29
  • ah, I see now. After enabling that option, the test fails in the same place for me as well. Any more information would have to come from the dev team. I suspect it may have to do with the storage request being for stackauth.com on a page served by stackexchange.com, but I'm not quite certain. – nhinkle Aug 5 '11 at 22:06
  • Great, I am not insane ;-> thanks. I also got some errors trying to log into the HP forums, different behavior though, but both cured now, I suspect it is a chrome bug, never did it on earlier versions as I have always had this checked on previous versions of chrome. – Moab Aug 5 '11 at 22:11
  • From doing some googling, it looks like that option will completely deny any third party cookies. While not stated upfront, that may also completely deny third party HTML5 LocalStorage, which could be causing this problem. Let's wait to see what a dev says. – nhinkle Aug 5 '11 at 22:20
  • 1
    In the meantime Moab, you can use the alternate escape hatch to get into chat: superuser.com/users/chat-stackexchange-login – nhinkle Aug 5 '11 at 22:23
  • For now I have disabled that feature, so I can chat for now, thanks. – Moab Aug 6 '11 at 14:20
2

The "block third-party cookies from being set" thing sounds plausible; some paranoia plugins may consider the localStorage used in a cross-domain IFRAME a third-party cookie.

The Stack Exchange global network login (also used for the chat.SE login) requires this to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .