3

hi,

my username has changed.

I can still log in with my openid and pswd.

could be a technical glitch?

how do I restore my username?

3

If you click your username on the top-bar, to get up your profile, there's an edit button just to the right of the words "Registered User", this will let you change your username (and other details, obviously).

As for why it changed, I don't know - anyone?

3
  • thanks.. I did that.. changed my name to what it was so it's not user343423 or whatever. Oddly now though, I see the edit option has gone, and there was also an Accounts tab, which had an option like "copy to all accounts" which I used to make the change copy to stackoverflow or whatever.. I did it.. Though oddly not only has the edit option gone, but that tab has gone also. I probably don't need them now. but would be good if they were there!
    – barlop
    Sep 14 '10 at 14:53
  • hmm.. the edit option and accounts tab exists on the parent site.. superuser and on SU and meta SU. (not that it matters) though not this one, or now on this one.
    – barlop
    Sep 14 '10 at 15:01
  • 1
    @barlop The child meta sites (that is every meta except meta.stackoverflow) are not seperate SE sites so you don't have a user account with them - you have an account with thier parent, and so cannot change details from the meta site, only the parent.
    – DMA57361
    Sep 14 '10 at 15:03
3

We are no longer inferring display names from openids; if you want a display name you must set one.

This is by design and will remain this way from this point onward.

Why?

  1. without a display name set nobody can @reply to you.

  2. it exposes part of your openid identifier.

1
  • Regarding the security risk pointed out in point 2, (that people could capture part of peoples' openid). Suppose I change my display name. The old replies @___ would have to change too. Is that possible?
    – barlop
    Sep 20 '10 at 11:40
2

apparently a solution here Username missing from Launchpad OpenID - replaced with user{number}

related My profile just went blank?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .