1

I noticed some changes in the log in on this site recently, and since then I am no longer able to log in to Super User, or Stack Exchange. I only have a Stack Exchange account.

When trying to log in from Stack Exchange, the only options that appear are: "Click here to sign up" and "Enter your OpenID"

From the Super User login window, everything seems to appear but the "Login" button is inactive (the other login options act the same - including the Facebook and Google login). I can press it, but nothing happens.

At my company there are some restrictions and a strong firewall. I do not know all of the rules and security policies in place.

I have local administrator account but I do not have access to the domain. I am using Internet Explorer. I would also prefer fixing the problem myself (if possible) instead of contacting the department who made the security policy.

How can I troubleshoot this and get a workaround?

migrated from superuser.com Aug 5 '15 at 15:21

This question came from our site for computer enthusiasts and power users.

  • This isn't anything you can do given your permissions this is a problem outside of your power to fix. – Ramhound Aug 5 '15 at 14:25
  • Did you try to add the site to the Trusted Sites in Internet Explorer ? That often convinces the browser to use a less strict security regime. Unless the sysadmins locked that down too. – Tonny Aug 5 '15 at 14:26
  • 1
    @Tonny - Yes, I did that and even lowered the security, it did not help. – user478482 Aug 5 '15 at 14:46
  • 1
    @Ramhound - since I have a local admin account, I am sure that there is a workaround this, there is only a policy that restricts me from using the button. – user478482 Aug 5 '15 at 14:47
  • 1
    @Tyson - this is a problem that needs straight answers, troubleshooting and solution. I do not want to discuss or to talk about bugs or anything similar. This question belongs here. I suggest You to read the meta help guide with more attention superuser.com/help/whats-meta – user478482 Aug 5 '15 at 14:49
  • 1
    @Ramhound - there might be a workaround. I just need suggestions where to search, this is why I created this post. I do not think anyone would blacklist only the login button of this site and allow the login to facebook, and other similar sites. I just need some information and ideas. This type of login method might not work on other websites as well. Sorry for my outbreak there, I just need ideas instead of blaming. – user478482 Aug 5 '15 at 15:16
  • "My browser seems not to work well with https and I need ideas how to find out what is going on." - This tells me it is a firewall configuration. Since you do not have the required permissions to modify the firewall this cannot be solved by you. I should point out that I also have the same problem with SE websites at work, when I attempt to login, the webpage loads without any layout and does not work. There is a work around if your SE account is connected to a Google Account though. I will again repeat that, this isn't a local browser setting problem, it cannot be solved on your end. – Ramhound Aug 5 '15 at 15:31
  • @Ramhound - Finally a helpful comment. I taught Tonny was the only one trying to help... - So, the thing is, that last week it was working. With the old login method, I could sign in without a problem. I also have the full layout. Everything seems to appear only the buttons are inactive. So what did change in the new login method of the site? If I am right, it used js, and it still does. – user478482 Aug 5 '15 at 15:41
  • 3
    @user478482: Your experience on the SE sites will be better (for everyone), if you can check the attitude. You posted in the wrong place and someone migrated it to the right place to get you an answer (using the appropriate Meta site tag). You added an obnoxious edit to your question. People took the time to explore your problem and you replied with obnoxious comments and personal attacks. That behavior has no place here. Rule #1: be nice. – fixer1234 Aug 5 '15 at 16:07
  • @fixer1234 - in my opinion I did post to the right place. Since the person migrating the post did it anonymously and without a warning, I can only message him by editing my post. I did not even had the chance to explain my point. It is like You compose your question and someone thinks it is not right and deletes it, without even giving the chance for You to edit it or explain why is it bad. I talked nice to people trying to help and focusing on the problem. I do not like being criticized without even being understood. – user478482 Aug 5 '15 at 16:34
  • @user478482 - 5 people voted to migrated your question. This wasn't done anonymously like you claim. There is full public record of who voted to migrated your question. Since you don't know who voted to migrated your question, I will tell you, it was myself, Ƭᴇcʜιᴇ007, Steven, heavyd, and Xavierjazz. Your question was not deleted it was migrated, to what 5 highly involved people of the community, thought it should go. You did NOT talk nice to me, I felt I was being personally attacked, and took your comment which you delete on my request as you calling me useless. – Ramhound Aug 5 '15 at 16:54
  • Everybody calm down. @user478482 I understand that the migration seemed like an affront, but it wasn't a personal knock against you. Folks here are trying to help. Please consider letting it go. – Ana Aug 5 '15 at 17:02
  • @Ramhound - The 5 persons were not visible to me. Also none of them gave me an option to edit my question and they did not gave me a single argument of why does it belong here. So I find their decision unfair. I never said that you are useless. All I said is: you should be helping instead of blaming. I apologize if I was brusque. I was waiting for some useful tips instead of blame. – user478482 Aug 5 '15 at 17:59
  • @Ana - Thank You for understanding my point. As soon as users started helping me instead of blaming, I immediately started talking nice to them. I still find the migration unfair, but I think this is how things go here. – user478482 Aug 5 '15 at 18:07
  • 1
    @user478482 questions about support or bugs with the Stack Exchange software and website itself belong here on Meta. We're happy to try to help you, but you need to let us help. Migrating your question to where it belongs isn't a slight towards you, it's just keeping things running smoothly and where they belong. – nhinkle Aug 5 '15 at 18:40
2

Very likely they are blocking some of the third-party javascript resources that Stack Exchange sites depend on. Unfortunately it's difficult to get an idea of what exact resources may be blocked without having an advanced browser that has good developer tools.

It should be possible to bypass your restrictive proxy, but I can't tell you to do that, nor can I tell you how.

  • I know in my case, the proxy that is set in my browser, is my internet connection. So there isn't a way to bypass it. – Ramhound Aug 5 '15 at 15:38
  • @Ramhound - yes the proxy is also present in my case as well. (Offtopic: I could bypass the firewall with google translate by translating some restricted sites - no js but at least I could read the content - this is why I say that most of the times there is a workaround). – user478482 Aug 5 '15 at 15:49
  • @allquixotic - there are lots of ways to bypass it, I know a few methods. I am just looking for a local way to do that, with a non complex solution. What browser could I use to get additional information? – user478482 Aug 5 '15 at 15:52
  • @Ramhound - what exactly do You mean by due to my attitude? Did I write a bad word when we were talking about the problem? As I said, I just need brainstorming and ideas about the problem. If you are not willing to help, than you do not have to. I asked, and you are not forced to answer. It is all optional. However I am grateful for writing your opinion and personal experience about the problem. Just spare me the "why is this post bad" and irrelevant parts. – user478482 Aug 5 '15 at 16:42
  • @Ramhound - If I am right, I need some reputation to be able to go into the chat. Of course I get upset if I am treated unfair. – user478482 Aug 5 '15 at 18:04
  • @user478482 - You were extremely hostile towards me. You were hostile towards anyone that indicate they believed this question didn't belong at Superuser. Your question was treated exactly like any other question, that the community believe was in the incorrect location, it was migrated to the correct location. Can you not see your "To the person migrating this post ...." comment as being a little passive aggressive? Despite having a great number of doubts you would appreciate an answer I still published one. – Ramhound Aug 5 '15 at 18:24
  • @Ramhound - not really. It was not intended to be offensive. Reading can sometimes seem more offensive than hearing. I was only sending a response to people who offended to me. Lets face it, this post was composed Q&A style. After the rules of SuperUser. – user478482 Aug 5 '15 at 18:26
  • @user478482 - Except the topic wasn't on topic for Superuser. This is more of a meta question, specifically something the developers can help with, which is the reason it was migrated. I more then anyone hear understand how the tone of a written statement is more often misunderstood. I deal with that daily from users of this community with regards to my extreme low context statements. You should take this time to get rid of that closing remark in your question, it isn't required, your question was migrated to the proper place. It was migrated so the question could be answered. – Ramhound Aug 5 '15 at 18:30
1

I have a similar problem while at work. I am not going to the effort to provide a screenshot of what the secure page looks like. I will describe what it looks like, the page does not fully load, which basically means required content is being blocked by the network. What content is loaded, when interacted with, does nothing.

I found if I copied the following URL I am able to log into Superuser. I don't have URL for any other Stackexchange website. This URL will only work if your Stackexchange account is connected to your Google Account and uses your Google Account OAuthentication.

  • is there a way to link your Exchange account to a Google account? – user478482 Aug 5 '15 at 16:09
  • @user478482 - You can get the same url yourself on a network you can log into. You just need url which you are redirected to when you hit login button. You should not have an authentication cookie already with SE when you attempt to get the URL. – Ramhound Aug 5 '15 at 16:12
  • This works, but what if I have a Hotmail account? Any ideas for that? – user478482 Aug 5 '15 at 18:18
  • @user478482 - I described the basic approach to get the authentication URL. It might not work for any other authentication other then Google Account OAUTH, if that is the case, it then falls on you to figure out which content is being blocked by the proxy. – Ramhound Aug 5 '15 at 18:23
  • This is the best solution so far. At least there is a partial workaround. I will do some more research about this. If you have any other ideas or information you feel to share and gets me closer to the solution or even can ring a bell for me, I would appreciate if you would comment it. – user478482 Aug 5 '15 at 18:33

You must log in to answer this question.