5

I've noticed that some questions that have been answered on ServerFault that eventually get migrated to SuperUser are not crediting me with the reputation that I gained on ServerFault, even though I lost the reputation on SF. An example is this question: "As a bar owner, how can I block guest from using specific programs, like Spotify, over my free wifi?"

I gained 13 upvotes for my answer on ServerFault before the question was migrated. I gained another 4 upvotes on SuperUser. I recalc'ed my rep on SF so that I wouldn't have an inflated reputation and lost the 130 reputation points, however, never gained those 13 upvotes on SU. I have recalculated my reputation on SU with no difference.

Wouldn't make a big deal out of it except:

  1. It could be a sign of bad things under the hood.
  2. There are a few privs that I want on SU, but I am not a regular contributor so every little bit counts. =)

EDIT: After some more consultation, it seems that people are experiencing this on other sites as well. For example, migrations from Security to ServerFault. Perhaps this is a site-wide problem? Should this be moved to the Uber Meta?

EDIT 2: Apparently as per this link, reputation is not migrated between sites. However, that simply has not been true at all times. I know for certain that at one point questions migrated from SF to SU caused me to lose the SF rep and gain the same amount of reputation on SU. For example, a question with 3 upvotes on SF would, when migrated, cost me 30 reps on SF and immediately gain 30 reputation points on SU even if no further upvotes on SU were gained for that question.

EDIT 3: I checked SU on April 5th 2011 and discovered that I had gained 200 points. My /reputation page shows that all reputation was gained on prior questions, and 180 points were gained from the question linked to in my first paragraph. Reputation appears to be migration now.

  • This also happened with me on: superuser.com/questions/243719 – Scott Pack Mar 24 '11 at 16:06
  • This does not need to be raised on Meta-opolis since the dev team sees across all child metas. – random Mar 24 '11 at 16:09
  • Your current reputation and votes on your posts suggests this was never the case – random Mar 24 '11 at 16:50
5

We recently fixed this bug, where migrated posts' upvotes didn't properly give reputation to the posts' owners, if those owners existed on the destination site at the time of migration.

We're working on fixing the bad reputation data. By next week, your reputation will properly include these migrated votes.

  • So this implies that a person is supposed to get the reputation points off of migrated questions? I seem to be getting conflicting information. It's all so confusing. =) – Wesley Mar 25 '11 at 6:32
  • @WesleyDavid: there was some outdated information on Jeff's answer - I've updated it. – Jarrod Dixon Mar 25 '11 at 6:42
  • Still a little unclear. Rep transfers over with the post or doesn't? – random Mar 25 '11 at 12:56
  • Thanks Jarod. Will you post an update somewhere when the bad data has been sent to its room without supper? – Wesley Mar 25 '11 at 16:02
  • @random I'll edit my post to clarify. – Jarrod Dixon Mar 25 '11 at 17:59
  • Was this successfully fixed? I saw a small adjustment to my reps that didn't correspond to any upvotes, but only 30 points. I would have assumed more of an adjustment based on just that one question alone (mentioned in my original post). – Wesley Mar 31 '11 at 19:37
  • It appears that the change has taken into effect. I just gained about 200 points all of a sudden. – Wesley Apr 6 '11 at 1:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .