-1

I tried to write this answer to a question. Every time I tried to type the variable name yas-snippet-dirs, a period was automatically added after that name, as soon as I typed a space char or a backtick. (The same happened for this question post.)

The workaround I found was to delete the final s from the variable name, insert a comma or other non-space char, and then go back and add the final s.

I am using IE11, in case that is relevant. (Not sure this is autocompletion, but something is inserting that period.)

(I searched for similar questions, but didn't find any. Please excuse if this is in fact a duplicate.)


UPDATE: Apparently that description was not clear enough. Let me try to clarify.

  1. I type "yas-snippet-dirs" (without the quotes).

  2. I type a space or a backtick.

    As soon as I do #2, the text I've typed changes to "yas-snippet-dirs." (without the quotes), followed by the space or backtick. A period was added automatically, just after "dirs".

  3. As a workaround, I then go back and remove the period.

The same thing happens with just the text "dirs", BTW -- no need for the prefix "yas-snippet-" to reproduce it.


Second UPDATE

Sorry for the noise. It was IE (plus my ignorance). I finally figured out how to turn off the spell-check. Sorry for the noise. Feel free to close this question.

closed as off-topic by nhinkle Apr 5 '14 at 4:45

  • This question does not appear to be a meta discussion about Super User or the software that powers the Stack Exchange network within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I'm having a hard time visualizing the issue you're describing, but I do not believe it is a feature/bug of Stack Exchange. It sounds like something in your browser. There is autocompletion on tags, but nothing in the content of a post is auto corrected in any way. – nhinkle Apr 5 '14 at 3:01
  • @nhinkle: I've tried to clarify the recipe, above. Yes, I thought it might be a browser thing. I tried googling for that, as well, with no luck. Perhaps someone else with IE11 can reproduce the problem, at least. FWIW, I haven't seen this problem in other edit fields (other web sites). Perhaps it has to do with the particular edit field implementation. I also see red squiggly spelling-mistake underlining and even automatic spelling "correction". That too I have not seen on other sites (but I don't edit on many sites). – Drew Apr 5 '14 at 4:25
  • @nhinkle: Problem solved -- see above. Why on Earth dirs was autocorrected to dirs. I have no idea. – Drew Apr 5 '14 at 4:43
  • you might as well open a question (and answer it yourself) on the main site on how to disable autocorrect in IE11. – nhinkle Apr 5 '14 at 4:44
  • This question appears to be off-topic because it is about a browser configuration problem, not an issue with Stack Exchange itself. – nhinkle Apr 5 '14 at 4:45
  • @nhinkle: No, I don't think I should open and answer that question. It is not the question I had. How to turn off spell-check is well-documented, both in the browser help and on the web. The problem was that I did not know that the browser was spell-checking, not that I couldn't figure out how to disable that. – Drew Apr 5 '14 at 4:47
1

This behavior is caused by IE11's auto-correct, not by any setting or feature of Stack Exchange. You can verify this yourself by visiting any page with a textarea and typing dirs.

A cursory google search shows many results for "disable IE11 autocorrect" but none of the results I found seemed to work.

  • See my updated post and replies to your comments. – Drew Apr 5 '14 at 4:43

Not the answer you're looking for? Browse other questions tagged .